<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>Hi ,<o:p></o:p></p><p class=MsoNormal>I was trying to integrate the libzmq3.2 with libev by registering zmq socket fd to event_loops . I am trying to use  inproc zmq_pair sockets for inter thread communicaton.<o:p></o:p></p><p class=MsoNormal>I have made some changes in zmq::pipe_t::flush in order to make it work<o:p></o:p></p><p class=MsoNormal>void zmq::pipe_t::flush ()<o:p></o:p></p><p class=MsoNormal>{<o:p></o:p></p><p class=MsoNormal>    //  The peer does not exist anymore at this point.<o:p></o:p></p><p class=MsoNormal>    if (state == terminating)<o:p></o:p></p><p class=MsoNormal>        return;<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>    if (outpipe && !outpipe->flush ())<o:p></o:p></p><p class=MsoNormal>        send_activate_read (peer);<o:p></o:p></p><p class=MsoNormal>   else<o:p></o:p></p><p class=MsoNormal>                send_activate_read(peer); //changes done for sending the commands (events) deliberately <o:p></o:p></p><p class=MsoNormal>}<o:p></o:p></p><p class=MsoNormal>Can you kindly validate these changes  and see if there are any repercussions in sending the activate_read even if the reader_thread is active<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal><br>Regards,<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p></div></body></html>