This is correct, python is binary incompatible across versions.

Regards,
Erich

On Thu, Dec 10, 2009 at 3:54 AM, Martin Sustrik <sustrik@250bpm.com> wrote:
Hi,

> I try to use zeromq in python 2.5,
> In linux, it works well, but in windows exception happens.
> '''
> ImportError: Module use of python26.dll conflicts with this version of
> Python
> '''
> I don't know whether zeromq supports python 2.5 in windows.
>
> I tested the version 0.6.0, 1.0.0 and 1.0.1, all can't works.
>
> But I found a page
> 'http://lists.zeromq.org/pipermail/zeromq-dev/2009-April/000667.html'
> the author seems using python 2.5.
>
> I am a newbie in zeromq.
>
> please help me.

I am a python expert, but my feeling is that python 2.5 & 2.6 are binary
 incompatible. Thus, python library (pyzmq.dll) compiled with python
2.6 won't work with python 2.5. You'll have to rebuild the project
(pyzmq) with your version of python.

Martin
_______________________________________________
zeromq-dev mailing list
zeromq-dev@lists.zeromq.org
http://lists.zeromq.org/mailman/listinfo/zeromq-dev