[zeromq-dev] TIPC support broken ???

joec infoark.com joec at infoark.com
Sun Mar 26 19:35:47 CEST 2023

Well...spent a bit more time screwing around with it...and voila..I got it working!

Very happy about this, but not exactly sure why I had an issue...I started and stopped TIPC several times,,,each trying different addressing.

Eventually, I dropped back to the defaults suggessted in the programs themselves (which I had previously tried and failed)...and it worked.

I had done some more research on the mailing lists about TIPC...still trying to grasp how the domain (@n.n.n) is used for though.

From: joec infoark.com
Sent: Sunday, March 26, 2023 11:06 AM
To: zeromq-dev at lists.zeromq.org <zeromq-dev at lists.zeromq.org>
Subject: TIPC support broken ???

Am new to zeromq and am evaluating using it for a new upcoming TIPC project.  I built the samples from https://gist.github.com/hintjens/7335589, then set it up accordingly.  Screwed around with it for a several hours but could never get it to work.

After reviewing the zmq TIPC logic, it seems since the TIPC 2 changes several years ago, it appears that TIPC features & addressing have changed considerably.  And despite the TIPC maintainers efforts to provide backward compatibility, zmq likely needs some changes to use the current version of TIPC today?

I'd like to be wrong about this, and hope someone might be able to confirm or deny the above?

Does anyone know of anyone currently using ZeroMQ w/TIPC transport?

Thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20230326/a05b3e70/attachment.htm>

More information about the zeromq-dev mailing list