[zeromq-dev] Udp on Travis errors?

Arnaud Loonstra arnaud at sphaero.org
Thu Jul 16 11:16:00 CEST 2020


On 16-07-2020 10:56, Luca Boccassi wrote:
> On Thu, 2020-07-16 at 10:33 +0200, Arnaud Loonstra wrote:
>> Hey all,
>>
>> I think we have some issues with UDP on travis. For example the
>> zbeacon_ipv4_mcast_test is skipped because it can't open the UDP socket.
>> (sock == INVALID_SOCKET)
>>
>> On some occasions zbeacon also fails with:
>> * zbeacon: D: (czmq_selftest) 20-07-16 08:00:20 zsys_udp_send: failed,
>> reason=Operation not permitted
>>
>> D: (czmq_selftest) 20-07-16 08:00:20 zbeacon: failed to transmit,
>> attempting reconnection. reason=Resource temporarily unavailable
>>
>> however the test still succeeds then. Somebody made this work apparently?
>>
>> Anyhow, I was working on a new zudp class which was on the czmq's todo
>> list. Although tests are working on my machine they don't on Travis.
>>
>> Anybody experience with travis and udp/ipv6?
>>
>> See the zudp branch here:
>> https://github.com/sphaero/czmq/blob/zudp/src/zudp.c#L394
>>
>> The failing travis here:
>> https://travis-ci.org/github/sphaero/czmq/jobs/708640774#L1895
>>
>> Feedback on the zudp class is also welcomed!
>>
>> Rg,
>>
>> Arnaud
> 
> I think the problem is broadcast, rather than UDP. UDP should work fine
> on Travis. That test will just skip if broadcast is not available.
> 
> Regarding IPv6, only the very old images support it (check libzmq) - so
> any test should check first if it works, and skip if not.
> 
> 

Thanks for that Luca, documentation about this on travis is scarce.

I found the is_ipv6_available method in libzmq. I'll see if I can use 
that in czmq.

On ipv6 there is no broadcast, only multicast. As there's not much to 
find on this it could be the case that it should just work and so I'm 
doing something wrong perhaps.

Rg,

Arnaud


More information about the zeromq-dev mailing list