[zeromq-dev] Windows 10 & ironhouse2.c

Luca Boccassi luca.boccassi at gmail.com
Sun Oct 15 21:40:48 CEST 2017


On Sun, 2017-10-15 at 17:06 +0000, Stephen Gray wrote:
> I'm trying to build and run https://github.com/zeromq/czmq/blob/maste
> r/examples/security/ironhouse2.c using Visual Studio 2015 compiler on
> Windows 10.
> 
> The code compiles just fine using dynamic linking; I then copy
> libzmq.dll & libczmq.dll to the same folder as the .exe.  I run the
> ironhouse2.exe and the Windows firewall pops up, I allow it
> through.  However something is not right at runtime, the 'server'
> sends but the 'client' just waits indefinitely to receive.  I've
> tried other tcp endpoints & adjusting the filepaths of the encryption
> certificate folder because Linux uses forward slashes and Windows
> uses backslashes but without success.
> 
> Interestingly https://github.com/zeromq/czmq/blob/master/examples/sec
> urity/ironhouse.c runs OK.
> 
> Please does anyone have any suggestions to solve the problem?
> 
> With thanks.

I think binding to * in Windows doesn't work, so try to bind the server
to tcp://127.0.0.1:9000

Kind regards,
Luca Boccassi
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20171015/f7d6b5f5/attachment.sig>


More information about the zeromq-dev mailing list