[zeromq-dev] Windows 10 & ironhouse2.c

Stephen Gray riskybizlive at live.com
Sun Oct 15 19:06:02 CEST 2017

I'm trying to build and run https://github.com/zeromq/czmq/blob/master/examples/security/ironhouse2.c using Visual Studio 2015 compiler on Windows 10.

The code compiles just fine using dynamic linking; I then copy libzmq.dll & libczmq.dll to the same folder as the .exe.  I run the ironhouse2.exe and the Windows firewall pops up, I allow it through.  However something is not right at runtime, the 'server' sends but the 'client' just waits indefinitely to receive.  I've tried other tcp endpoints & adjusting the filepaths of the encryption certificate folder because Linux uses forward slashes and Windows uses backslashes but without success.

Interestingly https://github.com/zeromq/czmq/blob/master/examples/security/ironhouse.c runs OK.

Please does anyone have any suggestions to solve the problem?

With thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20171015/f16300fb/attachment.htm>

More information about the zeromq-dev mailing list