[zeromq-dev] Behaviour change between 4.1.5 and 4.2.1?

Simon.Giesecke at btc-ag.com Simon.Giesecke at btc-ag.com
Tue Jan 17 12:50:54 CET 2017

Hi Luca,

I am setting HWM before connect/bind. 

I already tried to skip through the git log, but somewhat gave up, since I am too unfamiliar with the internals of ZeroMQ.

I am using tcp as transport (under Windows; it does not seem to matter whether select or poll is used).

Note: The issue I recently reported on github (https://github.com/zeromq/libzmq/issues/2305) is not the same as this one, but it came up when I tried to reproduce the issue described in my mail in a minimal setting.

Best regards

-----Ursprüngliche Nachricht-----
Von: Luca Boccassi [mailto:luca.boccassi at gmail.com] 
Gesendet: Montag, 16. Januar 2017 12:26
An: ZeroMQ development list
Betreff: Re: [zeromq-dev] Behaviour change between 4.1.5 and 4.2.1?

On Mon, 2017-01-16 at 10:32 +0000, Simon.Giesecke at btc-ag.com wrote:
> Hi,
> we have migrated from ZeroMQ 4.1.5 to 4.2.1 recently and I notice some behaviour change in some of our test cases. These cases are related to enforcing that some queues run full resp. the HWM is exceeded. Sorry I cannot be more precise at the moment; I tried to reproduce the behavioural differences with some reduced code example, but have not been successful so far. To enable me to facilitate a more focused reproduction of the issue, I have a general question in advance. Have there been any deliberate changes in behaviour between 4.1.5 and 4.2.1 that might be related to this? From reading the release notes, I did not find something that raised my attention.
> Best regards
> Simon

One major change is that setting HWM works also after connecting/binding, is that what you are doing?

There were many other bug fixes that can be seen in the git log, can't remember all of them off the top of my head

Also what transport mode are you using?

Kind regards,
Luca Boccassi

More information about the zeromq-dev mailing list