[zeromq-dev] Issue using zmq req-res with nodejs

Sean Robertson sprobertson at gmail.com
Sat May 14 20:28:51 CEST 2016


Try with v2.14.x, I was seeing some problems with 2.15 (potentially related
to https://github.com/JustinTulloss/zeromq.node/issues/523)

On Sat, May 14, 2016 at 3:37 AM, Doron Somech <somdoron at gmail.com> wrote:

> Pieter was working on new nodejs binding out of czmq, maybe you can use
> that?
>
> On Fri, May 13, 2016 at 8:50 AM, Prasad Ghawate <prasad.ghawate at anzu.org>
> wrote:
>
>> Hello,
>>
>>
>>
>> I am trying to get help on this past 2 days . We are using default
>> request response Patten for communication between different modules  on the
>> server after first deployment on GCP cloud, while load test we encounter
>> issue where for multiple requests at a time to a modules stops receiving
>> request at some point of time .
>>
>>
>>
>> Following are things we checked for this.
>>
>> 1.       Sample zmq req- response application as mentioned in below
>> email (was able to reproduced the issue, responding module hangs and does
>> not accept further requests.)
>>
>> 2.       Tired adding monitoring for socket event in sample ( didn’t
>> help). https://www.npmjs.com/package/zmq
>>
>> 3.       Found no issues with memory and CPU usages .
>>
>> 4.       Tried Setting up ZMQ_HWM = 0, ZMQ_SWAP etc. for the sample
>> program didn’t helped. http://api.zeromq.org/2-1:zmq-setsockopt
>>
>> 5.       Currently looking at http://zguide.zeromq.org/php:chapter4 for
>> reliable request response Patten .
>>
>>
>>
>> Am I checking in right direction ? please suggest.
>>
>>
>>
>> Regards,
>>
>> Prasad.
>>
>>
>>
>> *From:* Prasad Ghawate [mailto:prasad.ghawate at anzu.org]
>> *Sent:* Thursday, May 12, 2016 11:43 AM
>> *To:* 'zeromq-dev at lists.zeromq.org' <zeromq-dev at lists.zeromq.org>
>> *Subject:* Issue using zmq req-res with nodejs
>>
>>
>>
>> Hello,
>>
>>
>>
>> I am using zmq (request- response) with node js everything works well on
>> my development Ubuntu machine. But when i deploy code on Cloud GCP server
>> (Ubuntu). For multiple requests with pause of 100 ms the responder stops
>> receiving  requests. PFA  Please help. I am using npm zmq v 2.15.1 on both
>> dev and cloud server machine. I am using request response example from
>> http://blog.rastating.com/using-zeromq-with-node-js/ For testing with
>> 100 Ms interval instead of 1000 ms .
>>
>> Requester :
>>
>> [image: cid:image001.jpg at 01D1AD05.7F96DC50]
>>
>> Responder :
>>
>> [image: cid:image002.png at 01D1AD05.7F96DC50]
>>
>> Regards,
>>
>> Prasad
>>
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>>
>
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160514/feb9acbe/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 28555 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160514/feb9acbe/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 9412 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160514/feb9acbe/attachment.png>


More information about the zeromq-dev mailing list