[zeromq-dev] ZMQ_STREAM and incoming message size limit over TCP

Zarko Bulatovic zb10948 at gmail.com
Wed May 4 15:34:57 CEST 2016


Hi,

My incoming messages to stream socket are being split in < 8kB parts, while
I don't have any framing denomination on the ZeroMQ side. As I understand,
this is down to OS TCP sockets implementation cuting them to some MTU size,
but I don't see it. If I do tcpdump on my channel, I am seeing 20kB packets
being relayed from source to destination socket (dest is ZMQ_TCP).

I have tried raising the ZMQ_RCVBUF value for the socket, no luck. I have
also tried getting the limit from the underlying fd, which gets retreived
OK via zmq_getsockopt() with ZMQ_FD, but standard getsockopt() with
SO_RCVBUF on that fd yields an "Socket operation on non-socket" error.

I would appreciate any idea on how to tackle this issue. I can always
implement message integrity on my side but I wanted to utilize one of many
great ZMQ functionalities... :)

Best Regards,
ZB
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160504/17f00f3a/attachment.htm>


More information about the zeromq-dev mailing list