[zeromq-dev] Would like to be a Windows ZeroMQ mentor?

Osiris Pedroso opedroso at gmail.com
Mon Jan 18 21:31:13 CET 2016

Hi Peter,

I used git to clone libzmq master like this:
c:\> git clone https://github.com/zeromq/libzmq

I found the solution file for my DevStudio version here:

I opened it and when I built it, I get same errors are when I did get on
libzmq-4.1.4 clone:
1>c:\libzmq\src\curve_client.hpp(41): fatal error C1083: Cannot open
include file: 'sodium.h': No such file or directory

I tried running the script for building the Windows package:
c:\libzmq\builds\msvc\build>CALL buildbase.bat ..\vs2013\libzmq.sln 12
Same errors (result errorlog is attached).

I also tried the Python method, first installing Python 3.5.1 executables
then cloning the git repository for https://github.com/zeromq/pyzmq.
Searching the only disk in my laptop for .SLN (DevStudio solution files)
showed me that no new sln files were added since installing Python and


On Mon, Jan 18, 2016 at 11:40 AM Pieter Hintjens <ph at imatix.com> wrote:

> Hi Osiris,
> There are two ways to get going on Windows, that I know of.
> One is to take the PyZMQ package for Windows.
> Second is to take libzmq master; look in builds/msvc and you will see
> everything you need to build using VS2008 onwards.
> -Pieter
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160118/b6083374/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: build_12.log
Type: application/octet-stream
Size: 9288 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160118/b6083374/attachment.obj>

More information about the zeromq-dev mailing list