[zeromq-dev] no valid pollers on AIX 6.1

Mike Beddo Mike.Beddo at dataventures.com
Tue Dec 13 18:30:49 CET 2016


I tried zeromq/master on our AIX 6.1 machine (note that zeromq/master builds and passes tests on AIX 7.1 now). Couldn't get past the "Choosing polling system from ..." step in configure ...

configure: Choosing polling system from 'kqueue epoll devpoll pollset poll select'...
configure: error: None of 'kqueue epoll devpoll pollset poll select' are valid pollers on this platform

I then tried "configure --with-poller=pollset" but got:

configure: Choosing polling system from 'pollset'...
configure: error: None of 'pollset' are valid pollers on this platform

Finally, I tried "configure --with-poller=poll" but got:

configure: Choosing polling system from 'poll'...
configure: error: None of 'poll' are valid pollers on this platform

- Mike

-----Original Message-----
From: zeromq-dev [mailto:zeromq-dev-bounces at lists.zeromq.org] On Behalf Of Luca Boccassi
Sent: Monday, December 12, 2016 2:38 PM
To: ZeroMQ development list
Subject: Re: [zeromq-dev] no valid pollers on AIX 6.1

On Mon, 2016-12-12 at 21:06 +0000, Mike Beddo wrote:
> Trying to build zeromq 4.1.6 on AIX 6.1. When running "configure CC=xlc CXX=xlC", configure exits with the error:
> 
> configure: Choosing polling system from 'kqueue epoll devpoll poll select'...
> configure: error: None of 'kqueue epoll devpoll poll select' are valid 
> pollers on this platform
> 
> This same distribution builds fine on AIX 7.1. We need zeromq library built for both AIX 6.1 and 7.1.
> 
> 
> -          Mike Beddo

Hi,

A new poller (pollset) was added in 4.2.0 specifically for AIX, could you please try with that version?

Kind regards,
Luca Boccassi


More information about the zeromq-dev mailing list