[zeromq-dev] Test failing on OS X 10.9.4

Osiris Pedroso opedroso at gmail.com
Wed Apr 6 23:05:29 CEST 2016


I live in Alabama, USA. CST (GMT+6, currently +5 due to daylight savings).

You did not break them. I was not even running with your changes.

These tests have failed for me for a long time on fresh source from github
(no chages) on this Ubuntu machine I setup exclusively for ZeroMQ.
I just thought the failures were consistent in all platforms, but seems
like they are not.

I just make sure to run the tests on a fresh build, make my changes and if
the same tests fail aferwards, I consider I have hopefully not introduced
any new problems which happen to be in one of the broken tests already.


On Wed, Apr 6, 2016 at 2:32 PM Matjaž Ostroveršnik <
matjaz.ostroversnik at gmail.com> wrote:

> Hi Osiris,
>
> Which time zone you are living in? You are non stop on-line. Thanks, I
> appreciate your fast check.
> What are those 4 failed tests?
> I don't remember touching them.
>
> Best regards
>
>
> Matjaž
>
>
> On 6.4.2016 19:45, Osiris Pedroso wrote:
>
> Lucky you,
>
> Ubuntu 14.04 results:
>
>
> ============================================================================
> Testsuite summary for zeromq 4.2.0
>
> ============================================================================
> # TOTAL: 78
> # PASS:  74
> # SKIP:  0
> # XFAIL: 0
> # FAIL:  4
> # XPASS: 0
> # ERROR: 0
>
> ============================================================================
> See ./test-suite.log
> Please report to zeromq-dev at lists.zeromq.org
>
> ============================================================================
>
> FAIL: tests/test_term_endpoint
> ==============================
>
> lt-test_term_endpoint: tests/test_term_endpoint.cpp:136: int main():
> Assertion `rc == 0' failed.
>
> FAIL: tests/test_ipc_wildcard
> =============================
>
> lt-test_ipc_wildcard: tests/test_ipc_wildcard.cpp:41: int main():
> Assertion `rc == 0' failed.
>
> FAIL: tests/test_xpub_manual
> ============================
>
> lt-test_xpub_manual: tests/test_xpub_manual.cpp:108: int
> test_xpub_proxy_unsubscribe_on_disconnect(): Assertion `zmq_bind
> (xsub_proxy, frontend) == 0' failed.
>
> FAIL: tests/test_filter_ipc
> ===========================
>
> lt-test_filter_ipc: tests/test_filter_ipc.cpp:100: void run_test(int, T,
> int, int) [with T = int]: Assertion `rc == 0' failed.
>
> On Wed, Apr 6, 2016 at 5:14 AM Shital Mehta <smcal75 at gmail.com> wrote:
>
>> ====================================
>>    zeromq 4.2.0: ./test-suite.log
>> ====================================
>>
>> # TOTAL: 78
>> # PASS:  77
>> # SKIP:  0
>> # XFAIL: 0
>> # FAIL:  1
>> # XPASS: 0
>> # ERROR: 0
>>
>> .. contents:: :depth: 2
>>
>> FAIL: tests/test_shutdown_stress
>> ================================
>>
>> Invalid argument (src/stream_engine.cpp:136)
>>
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>>
>
>
> _______________________________________________
> zeromq-dev mailing listzeromq-dev at lists.zeromq.orghttp://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20160406/b93139cf/attachment.htm>


More information about the zeromq-dev mailing list