[zeromq-dev] How to install and run multiple versions of zmq on one machine?

Houwu Bai bai.houwu at gmail.com
Thu May 14 20:06:09 CEST 2015


Hi,

I need to design/implement a system with: 1) Node.js at the frontend to
handle HTTP clients, and 2) Scala/Akka backend services. The idea is to use
zmq sockets as the communication channels between Node.js frontend and Akka
backend (and possibly other micro-services implemented in other programming
languages). However, an issue with Scala/Akka is that akka-zmq module is
current only compatible with zmq 2.x, while Node.js supports zmq 4.0.5.

Is there a way to install and run multiple versions of zmq on one machine?
Or, actually the zmq sockets used by Node.js frontend and Akka backend have
to be in the same version?

Thanks,
Houwu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20150514/91dacddb/attachment.htm>


More information about the zeromq-dev mailing list