[zeromq-dev] ZeroMQ and NORM

Adam Najman najman at gmail.com
Wed Mar 11 15:03:12 CET 2015

I'm trying to establish a NORM connection using ZeroMQ as detailed here:


I've already built NORM and ZeroMQ with support for norm using ./configure

The code I'm trying is as follows:

#Subscriberimport zmq
context = zmq.Context()
socket = context.socket(zmq.SUB)
socket.setsockopt(zmq.SUBSCRIBE, "ZMQ-Test")while True:
    string = socket.recv()
    print string
#Publisherimport zmqimport time
context = zmq.Context()
socket = context.socket(zmq.PUB)
i = 1while True:
    topic = "ZMQ-Test"
    message = "Hello, NORM " + str(i) + " …"
    socket.send("%s %s" % (topic, message))
    i += 1

Whenever I run either of these, I get an error message:

Traceback (most recent call last):
  File "pub.py", line 5, in <module>
  File "zmq/backend/cython/socket.pyx", line 471, in
zmq.error.ZMQError: Protocol not supported

I've tried re-installing everything and building everything from scratch,
including NORM ZeroMQ and PyZMQ. Can anyone help with this issue? Python
Version: 2.7.9 NORM Version: 1.5b4 ZeroMQ Version: 3.2.5
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20150311/54ba4671/attachment.htm>

More information about the zeromq-dev mailing list