[zeromq-dev] Last value cache example not working

Ingar Pedersen ifp.hj at online.no
Fri Jun 19 15:37:23 CEST 2015


 

Hi, 

I have been going through the greate guide, and running all the
examples. 

However I'm getting stuck on the last value cache example... 

I have built all the source on linux and on windows and I'm getting the
same result on both OS. 

I run the lvcache program, then the pathopub and finally pathosub.
lvcache prints "sending cached topic xxx" but nothing is receive by the
subscriber. 

I have debugged lvcache on widows (VS2012) and it seems nothing is
received from the publisher ever... When I single step the publisher it
seems all messages are dropped because there are no subscribers, but I
am not to familiar with the source yet to be 100% sure about this... 

If I'm running without lvcache and using the 5556 port directly from
publisher to subscriber it also works as expected. 

Now for the funny thing: If I build the C# example I'm getting the
expected result, and all is built using the same libzmq... 

Any ideas why it fails when running with lvcache?? 

I have checked and tripple checked the setup, and I'm using
tcp://127.0.0.1:5557 for the publisher and tcp://127.0.0.1:5558 for the
subscriber... 

Thanks! 

best regards 

Ingar F Pedersen 

 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20150619/b965169b/attachment.htm>


More information about the zeromq-dev mailing list