[zeromq-dev] Problem with not receiving message on one side of the pipeline.

Pieter Hintjens ph at imatix.com
Tue Jun 9 21:07:20 CEST 2015


I'd suggest you use DEALER-DEALER in that case. Note however that
it'll only work when you have one server and one GUI.

On Tue, Jun 9, 2015 at 7:19 PM, Igor Lopez <igor.lopez at bredband.net> wrote:
> 2015-06-01 19:49 GMT+02:00 Igor Lopez <igor.lopez at bredband.net>:
>>
>> Hi this is my first post to the list so bear with me if I am not following
>> the standard way of posting.
>>
>> I have written a small application in Python (v 3.4) using the latest
>> zeromq found in Ubuntu 14.04 (sudo python3.4 pip install pyzmq). With latest
>> I mean that I configured my PC with zeromq and the python bindings
>> approximately 3 weeks ago.
>> The app consist of one server and one GUI where the server will constantly
>> handle an external piece of hardware while simultaneously respond to
>> requests from the GUI.
>> The requests sent from the GUI gets through to the server but the response
>> from the server is not picked up by the GUI.
>>
>> Since I visit Stackoverflow a lot I posted there first but then decided to
>> test this list.
>>
>> If you want to have a look, see the following link:
>>
>> http://stackoverflow.com/questions/30546054/python-gui-not-capturing-zeromq-message
>>
>> /Igor
>>
>>
>
> If anybody is interested, the solution is to use REQ/REP sockets instead of
> PUSH/PULL.
>
> /Igor
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>



More information about the zeromq-dev mailing list