[zeromq-dev] libczmq.so.3.0.0 while gentoo package installed is 3.0.2?

Benjamin Henrion zoobab at gmail.com
Wed Dec 23 10:15:20 CET 2015


Hi,

I have installed czmq on my gentoo via:

sudo emerge -1 "=net-libs/czmq-3.0.2"

First I had to patch it to comment this line to make it work,
otherwise it would not install:

src_install() {
    autotools-utils_src_install
    mv "${ED}"/usr/bin/makecert{,-czmq} || die
#   mv "${ED}"/usr/share/man/man1/makecert{,-cmzq}.1 || die
}

Second, when I was trying to compile malamute, and it failed at
./configure because it was not finding libczmq.so.3.0.1 at minimum.

I finally solved the ./configure issue by renaming by hand
libczmq.so.3.0.0 to libczmq.so.3.0.2.

Any idea why?

I feel this is the same issue with all the tarballs released on github?

Best,

--
Benjamin Henrion <bhenrion at ffii.org>
FFII Brussels - +32-484-566109 - +32-2-3500762
"In July 2005, after several failed attempts to legalise software
patents in Europe, the patent establishment changed its strategy.
Instead of explicitly seeking to sanction the patentability of
software, they are now seeking to create a central European patent
court, which would establish and enforce patentability rules in their
favor, without any possibility of correction by competing courts or
democratically elected legislators."



More information about the zeromq-dev mailing list