[zeromq-dev] Send and receive using link-local IPv6 address using zmq 3.2.3 and czmq 1.4.1

Steven McCoy steven.mccoy at miru.hk
Wed Sep 10 13:49:00 CEST 2014

On 10 September 2014 01:49, Gerrit Hendrikus van Doorn <
g.h.vandoorn at gmail.com> wrote:

> > And the same address?  Those are not the most helpful examples to
> provide.
> > Do the non-CZMQ versions work?  Do you have ip6tables running?
> I mentioned that I run the applications on the same machine (to simplify
> the setup). I get the same results with ip6tables enabled or disabled.
> What would be a better example?
> eth0      Link encap:Ethernet  HWaddr A0:D3:C1:04:9F:60
>           inet addr:  Bcast:  Mask:
>           inet6 addr: fe80::a2d3:c1ff:fe04:9f60/64 Scope:Link
> So, running them on the *same* machine with:
> ./zmq_server tcp://[::1]:54321
> ./zmq_client tcp://[fe80::a2d3:c1ff:fe04:9f60%%eth0]:54321
> Results in the server binding correctly to [::1]:54321 but the client
> never receiving anything (block on recv). When I run the client using:
> ./zmq_client tcp://[::1]:54321
> I do receive data. However, I don't want to use the loopback address.
This is how IP networking works, you are specifying completely different
networks and they correctly do not communicate with each other.  Are you
looking for the IPv6 wild card address? "[::]".

  ./zmq_server tcp://[::]:1234

  ./zmq_client tcp://[::1]:1234
  ./zmq_client tcp://[fe80::a2d3:c1ff:fe04:9f60%%eth0]:1234

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140910/47815d91/attachment.htm>

More information about the zeromq-dev mailing list