[zeromq-dev] Windows build for zeromq-4.1.0-rc1 does not load in VS2013

Dan Mick dan.mick at inktank.com
Thu Oct 16 22:22:05 CEST 2014


This seems connected to something I tried to fix recently; that whole
properties tree got reorganized, but the packaging had not followed
suit; I pushed a 'fix' for the packaging but had no way to test the
Windows stuff, so may have broken it (or insufficiently fixed it).

My cleanup commit was de4a442263456213f49a46428b4b2fe8a7ea47d4, trying
to help sand the rough edges off evoiskuil's
86ef40d17108f0c49d4d9746e5bc3c7851ce2896 and
4e5921b7abc5efbef94b7699f3eaa7493c7cd08b.  If I broke it, I apologize; I
was only trying to make "make dist" work on Linux.


On 10/16/2014 12:58 AM, Jim Idle wrote:
> Hi,
> 
> Iam sure that this is probably just an omission of a file that should be
> in the tarball, but it prevents rc1 from building with VS2013. Is it
> possible to remake the tarball or otherwise offer guidance.
> 
> When opening the .sln file, we receive:
> 
> 
> C:\Users\xxx\Downloads\zeromq-4.1.0-rc1\zeromq-4.1.0\builds\msvc\vs2013\libzmq\libzmq.vcxproj
> : error  : Unable to read the project file "libzmq.vcxproj".
> C:\Users\xxx\Downloads\zeromq-4.1.0-rc1\zeromq-4.1.0\builds\msvc\vs2013\libzmq\libzmq.vcxproj(65,5):
> The imported project
> "C:\Users\xxx\Downloads\zeromq-4.1.0-rc1\zeromq-4.1.0\builds\msvc\properties\Debug.props"
> was not found. Confirm that the path in the <Import> declaration is
> correct, and that the file exists on disk.
> 
> This file does not seem to be present. 
> 
> Thanks in advance for any assistance.
> 
> Jim
> 
> 
> 
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> 



More information about the zeromq-dev mailing list