[zeromq-dev] [Proposal] - JeroMQ to use Java 1.7

Arnaud Kapp kapp.arno at gmail.com
Sun Nov 23 00:18:27 CET 2014


Hello,

I am not familiar with JeroMQ and not too much with Java, so take my
inputs carefully :P.

> but I accidently released v0.3.4 with Java 1.7 and it's proved not to be a problem.
This is a good sign.


What are the advantages of supporting >= 1.7 only (and thus dropping
support for 1.6) ? Are there benefits for the JeroMQ devs/maintainer?

I want to say, if its free to support 1.6 then we should support it.
However, if takes time to maintain it then I don't know.

On Fri, Nov 21, 2014 at 5:00 PM, Trevor Bernard
<trevor.bernard at gmail.com> wrote:
> Hi,
>
> I propose we bump the minimum supported Java version to 1.7 since Java
> 6 is already end of life. Originally I was leary of doing this because
> I believed it would break peoples code but I accidently released
> v0.3.4 with Java 1.7 and it's proved not to be a problem.
>
> Thoughts?
>
> -Trevor
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev



-- 
Kapp Arnaud - Xaqq



More information about the zeromq-dev mailing list