[zeromq-dev] multicast chat working only with DHCP networks

Andrew Simpson simpsonar77 at yahoo.com
Mon May 12 02:23:25 CEST 2014


when I don't use DHCP, I statically set my network to an IP address, with a proper netmask and gateway.

The routing table was not from using DHCP.  It was from me manually setting an IP address: 

ifconfig eth0 172.20.20.200 netmask 255.255.255.0 
I've done the route adds with 172.20.20.1.  I've also tried 192.x.x.x  and 56.168.x.x network setups.

I've also tried a route add -net 224.0.0.0 netmask 240.0.0.0 dev eth0 with no success.  It only works if I either switch to using dhcp or manually setting an IP to 192.168.2.xxx and adding "nameserver 192.168.2.1" to /etc/resolv.conf.

As an example, if I set 2 computers up at 56.168.5.2 and 56.168.5.3 and give them both a default gateway of 56.168.5.1, the chat application will not work and gives me the previous error I listed.  If I take those, and add them to any DHCP based network, the two computers can talk using the 239.0.0.1 multicast address




wh 
On Sunday, May 11, 2014 9:28 PM, Arnaud Loonstra <arnaud at sphaero.org> wrote:
 
On 05/11/2014 09:29 PM, Andrew Simpson wrote:
>> by 0MQ multicast, I meant that I am using zeroMQ to make a chat program
>> that is using multicast addresses to send out to other nodes on a local
>> network.  this is a fairly simple application.  When it attempts to bind
>> to the multicast address, it gives the aforementioned error, unless I'm
>> on a proper network.
>>
>> I'll see if I can make a small test version of this program.  At the
>> very least I can probably post up the relevant parts of the code.
>> Thanks!
>
>I don't know if I understand your situation correctly but you need an IP 
>setup in order to do IP (including multicast). If you say it works with 
>DHCP how is your setup without DHCP? Does your NIC have an ipaddress at 
>all? The routing table you showed is from with DCHP right?
>
>If you do use a manual setup like 192.168.5.x does it work if you add a 
>route to it? Like 'route add -net 0.0.0.0 dev eth0' or something like that?
>
>Rg,
>
>
>Arnaud
>
>-- 
>w: http://www.sphaero.org
>t: http://twitter.com/sphaero
>g: http://github.com/sphaero
>i: freenode: sphaero_z25
>_______________________________________________
>zeromq-dev mailing list
>zeromq-dev at lists.zeromq.org
>http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140511/ac751025/attachment.htm>


More information about the zeromq-dev mailing list