[zeromq-dev] Hilarious(?) weird error when using PyZMQ 14.1.1 + zmq.auth.create_certificates()

Jonas Thiem jonasthiem at googlemail.com
Fri Mar 28 10:23:39 CET 2014


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi *,

Traceback (most recent call last):
File "./keycertgen.py", line 44, in <module>
zmq.auth.create_certificates(path, "key")
File "/usr/lib64/python3.3/site-packages/zmq/auth/certs.py", line 67,
in create_certificates
public_key, secret_key = zmq.curve_keypair()
File "utils.pyx", line 51, in zmq.backend.cython.utils.curve_keypair
(zmq/backend/cython/utils.c:801)
File "/usr/lib64/python3.3/site-packages/zmq/error.py", line 127, in
_check_rc
raise ZMQError(errno)
zmq.error.ZMQError: Success

It is quite amusing in a way, but still I would prefer if it actually
worked.
Same problem when calling zmq.curve_keypair() directly (not really
surprising since that is also what zmq.auth.create_certificates
appears to use from the callback).

Any ideas what I need to do so zmq.curve_keypair() works properly?

Regards,
Jonas Thiem
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJTNT+RAAoJEBIDTbbx8Yke7iIP/1l4SK2CUW7aUJmuTKC9/14L
WN88amkOjPr74uK2Kjxx1+aDHQQq81A6bMYdUzOz2hGFDvm0NFAORR+reO1f0qob
zW0U3LSyxp2ef+5IYqGKGzkXaorbHO/pLp6rEVvQnCIRISqvLg1vfinkY7ewRw1m
MTcq2olxUFfDMDlSqIaADY0ODtbZQWRHg29hQKYXR/i5/tlRlPfJeAR3uKnrgLKn
LEjt4Yd/bG32KQG9BFjFQpshmzoths+S5/1I40DO7K0JKhgC5jR2uuvICSFvh56U
Ai3QCG4PlQ8yw+geuExiT+FrrL+cKL6h/DJCjhK7pxcNK8hkLsPGmSygVFzwHyW3
VJSPMubwWe74F1WdiIECBm6V3535+Om31mDTl3sauKfHFqiic3ym+VG2LSRGtB2d
bRkzWwWF0G1SQI6acjs/si4I/YF+/sh3wPm4d2Thf+jjYnLdX8ZJLPExFix9DK6N
0hgOP7y3Ov4Xi+VeAYIzNlP5LTcjfglKJVOxnzWe3nnq/B6vtzausbEtTaGSuFoa
L+S7zqvqsKGcTtKGn2ZVNanK040SrvACW7MhjwHnwtQjcP/zFkzn0v9t02wRJSP6
5XlJkXu8xp4f0QpN6kGxXsRrwzebjvPWKpW0Lf8BJqyF+rQ5K//X4I6H3hPtPucg
fEmJDI5GsoHcoLbj89T9
=MEGJ
-----END PGP SIGNATURE-----



More information about the zeromq-dev mailing list