[zeromq-dev] API changes from 4.0 to 4.1

Pieter Hintjens ph at imatix.com
Mon Jun 23 19:52:09 CEST 2014


On Fri, Jun 20, 2014 at 6:44 PM, Peter Kleiweg <pkleiweg at xs4all.nl> wrote:

> A socket connect for these two addresses return no error. With
> version 4.0 they both return the error "invalid argument":
>     "tcp://localhost:invalid"
>     "tcp://in val id:1234"

That's strange, and not normal. I'll investigate.

> The Go version of test_security_curve fails.

This could be due to various things. I don't think we modified the
curve test case since 4.0. Can you investigate?

I'm collecting 4.1 upgrade notes here: http://zeromq.org/docs:4-1-upgrade

-Pieter



More information about the zeromq-dev mailing list