[zeromq-dev] API changes from 4.0 to 4.1

Peter Kleiweg pkleiweg at xs4all.nl
Fri Jun 20 19:01:23 CEST 2014



I noticed the same Go programs compiled with ZeroMQ 4.1.0 link 
to a bunch of libraries that were not linked with 4.0.4. These 
libraries:

       libcom_err.so.2 => /lib/libcom_err.so.2
       libdl.so.2 => /lib/libdl.so.2
       libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2
       libk5crypto.so.3 => /usr/lib/libk5crypto.so.3
       libkeyutils.so.1 => /lib/libkeyutils.so.1
       libkrb5.so.3 => /usr/lib/libkrb5.so.3
       libkrb5support.so.0 => /usr/lib/libkrb5support.so.0
       libresolv.so.2 => /lib/libresolv.so.2
       libzmq.so.4 => /my/opt/zeromq-4.1.0/lib/libzmq.so.4

Could this lead to changed behavior?

This is on Debian Squeeze, amd64.



-- 
Peter Kleiweg
http://pkleiweg.home.xs4all.nl/



More information about the zeromq-dev mailing list