[zeromq-dev] PUB/SUB unreliabiliity

Gerry Steele gerry.steele at gmail.com
Mon Jun 16 12:49:50 CEST 2014


Thanks Peter. I can't try this out till I get home but it is looking like
hwm overflows.

If you run the utilities you notice the drops start happening after
precisely 1000 events in the first instance (which Is the default hwm).

There was another largely ignored thread about this recently mentioning the
same problem.

I also tried setting the hwm values to a number greater than the number of
events and it seemed to have no effect either.

g

On 16 Jun 2014 09:32, "Pieter Hintjens" <ph at imatix.com> wrote:

> On Mon, Jun 16, 2014 at 9:10 AM, Gerry Steele <gerry.steele at gmail.com>
> wrote:
>
> > Big chunks of messages go missing mid flow and then pick up again. There
> is
> > no literature that indicates that is expected behaviour.
>
> Right. The two plausible causes for this are (a) HWM overflows, and
> (b) temporary network disconnects. You have excluded (a), though to be
> paranoid I'd probably add some temporary logging to libzmq's pub
> socket to shout out if/when it does hit the HWM. To detect (b) you
> could use the socket monitoring.  The third possibility is that you're
> doing something wrong with subscriptions... though that seems
> unlikely.
>
> -Pieter
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140616/3747bc7a/attachment.htm>


More information about the zeromq-dev mailing list