[zeromq-dev] Cannot find -lzmq

Marcell Havlik havlikmarcell at gmail.com
Thu Jul 10 10:47:25 CEST 2014

The question sounds pretty easy, but somehow I couldn't make my project
work with the proper linking.

My operating system is windows 7 x64.
I am using Cygwin x64 1.7.30, gcc 4.8.3
And I am using Eclipse to build my program, that I want to write in c++.

I installed ZemoMQ 4.0.4, and I set the include path to OMQ, and I put my
zmq.hpp in the include folder of OMQ. I set library search path to:
"/cygdrive/c/Program Files/ZeroMQ 4.0.4/lib" and even tried "C:\Program
Files\ZeroMQ 4.0.4\lib", and the flag zmq is also set.
I tried every possible way that I could immagine, combined everything with
everything but Something is still wrong.

I am still getting the error on my test app:
Invoking: Cygwin C++ Linker
g++ -L"/cygdrive/c/Program Files/ZeroMQ 4.0.4/lib" -L"C:\Program
Files\ZeroMQ 4.0.4\lib" -o "C11tesztje.exe"  ./src/C11tesztje.o   -lzmq
/usr/bin/ld: cannot find -lzmq
collect2: error: ld returned 1 exit status
makefile:45: recipe for target 'C11tesztje.exe' failed
make: *** [C11tesztje.exe] Error 1

Can anyone explain what do I do wrong or what else should I do?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140710/313af101/attachment.htm>

More information about the zeromq-dev mailing list