[zeromq-dev] libzmq.so.3 for zeromq4-x

Klaus Ita koki.eml at gmail.com
Tue Jan 14 09:36:28 CET 2014


Hi fellow zeromqers!

I am currently working on updating our ZMQx::Class package to ZMQ::FFI and
zmq4. What really jumps to my view is that build scripts generate
libzmq.so.3 and libzmq.so.3.1.0 but the version reports as 4.0.4. Would it
make sense to call the files libzmq.so.4.0.4 so we can have multiple
versions of zeromq installed on the same machine?

The only explanations i would have for the current implementation is that

1.) the code just did not get updated (fair, i would like to help here)
2.) the API has not changed, there is no reason for renaming (but then, why
bounce the release number?).

Thank you for your valuable feedback on this!

lg,k
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140114/45c45ebc/attachment.htm>


More information about the zeromq-dev mailing list