[zeromq-dev] "Identity" concept

Pieter Hintjens ph at imatix.com
Fri Jan 3 16:46:44 CET 2014


So consensus seems to be on "routing_id" as a replacement. I'll leave
this to settle for a while and then make a change (keeping the old
name for backwards compatibility).

On Fri, Jan 3, 2014 at 7:13 AM, Pieter Hintjens <ph at imatix.com> wrote:
> Hi all,
>
> See https://github.com/zeromq/libzmq/issues/805
>
> The "identity" concept has always been confusing and misnamed. This is
> especially visible when we do authentication. What this concept
> actually does is define a routing name. I'm not sure what a better
> name than "identity" would be, but would like to discuss this.
>
> -Pieter



More information about the zeromq-dev mailing list