[zeromq-dev] question about the documentation to provide when adding a set of functions

Pieter Hintjens ph at imatix.com
Thu Feb 6 12:40:57 CET 2014


Nice. The type for the API should be zmq_proxy_t. I hope you feel this
API style is clearer. It has helped our C code a lot.

On Thu, Feb 6, 2014 at 12:09 PM, Laurent Alebarde <l.alebarde at free.fr> wrote:
> Thanks Pieter, I have updated in conformance to RFC 21 (not checked all the
> details):
>
> https://github.com/lalebarde/libzmq/commit/5440e9732d8f449abf8acdcb6cb8679dd11734d6
>
> Cheers,
>
> Laurent
>
>
> Le 05/02/2014 21:14, Pieter Hintjens a écrit :
>
> You can see how to do C API design in e.g. CZMQ, or RFC 21:
> http://rfc.zeromq.org/spec:21
>
> On Wed, Feb 5, 2014 at 6:43 PM, Laurent Alebarde <l.alebarde at free.fr> wrote:
>
> Le 05/02/2014 12:51, Pieter Hintjens a écrit :
>
> typedef struct zmq_proxy_open_chain_t {unsigned char _ [496];}
>
> Again, seriously? Magic numbers? We do this for zmq_msg for
> unfortunate historic reasons. It is _very bad_ API design.
>
>
> Replaced by an opaque void pointer, eliminating this awful trick.
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>



More information about the zeromq-dev mailing list