[zeromq-dev] question about the documentation to provide when adding a set of functions

Laurent Alebarde l.alebarde at free.fr
Wed Feb 5 18:43:56 CET 2014


Le 05/02/2014 12:51, Pieter Hintjens a écrit :
>> typedef struct zmq_proxy_open_chain_t {unsigned char _ [496];}
> Again, seriously? Magic numbers? We do this for zmq_msg for
> unfortunate historic reasons. It is _very bad_ API design.
>
>
Replaced by an opaque void pointer, eliminating this awful trick.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20140205/abe9f6fe/attachment.htm>


More information about the zeromq-dev mailing list