[zeromq-dev] question about the documentation to provide when adding a set of functions

Pieter Hintjens ph at imatix.com
Wed Feb 5 12:51:50 CET 2014

On Wed, Feb 5, 2014 at 12:36 PM, Laurent Alebarde <l.alebarde at free.fr> wrote:

> If you have another suggestion for 'zmq_proxy_open_chain' that makes more
> sense for you, I will change it. But with my explanations and
> justifications, I find it right IMHO and have no other suggestion myself.

I'm still mystified why you're adding this complexity to the core API,
you've not explained what *problem* you're solving. That means, what
you are trying to do that you CANNOT do today.

What is a "proxy open chain"?


Seriously? You think this is OK?

> typedef struct zmq_proxy_open_chain_t {unsigned char _ [496];}

Again, seriously? Magic numbers? We do this for zmq_msg for
unfortunate historic reasons. It is _very bad_ API design.

Look, Laurent, our process calls for small incremental improvements
that fix agreed problems. Please read RFC 22 again if you're unsure.

You're making a mess here. I don't like messes in our core library.

Please take this API out again, until you get some consensus from the
list on the need for it. Then, make it in minimal steps.

If you make this patch I'll merge it, and then I shall remove it.
There is zero reason to be making complex proxy layers in libzmq. Even
in CZMQ I've had to remove all calls to zmq_proxy_steerable and write
my own proxy code, it's much simpler and backwards compatible.

Thanks for keeping things simple. Less is more.


More information about the zeromq-dev mailing list