[zeromq-dev] zmq 3.2 pgm Pub/Sub filtering and different host limitation

Mo Ling 0mq at linglink.com
Thu Sep 19 19:36:56 CEST 2013

Hi All,

Using the wuserver and wuclient example programs on Linux (Fedora 17,
x86_64, zeromq3-devel-3.2.2 rpm, also tried this using 3.2.3 as well) I
have observed the following behavior when using the pgm transport:

1) wuclient on a different machine can receive messages only if filter is
blank.  e.g. receive all messages.  Once the filter is enabled (e.g. set to
"10001 "), the client is not notified of any messages that match the
filter.  tcpdump indicates that the machine is receiving packets.

2) wuclient on same machine cannot receive any messages (filtered or not)

Switching to tcp works ok.

is 1) a known issue?

for 2), zeromq 2.x worked properly for collocated client/server.  What is
the reason to require client and server to be on different machines?  Is
this a consequence of not using uuid?  How would you unit test this?  This
is a major behaviour change from 2.x.  Any suggested work around for this
limitation (duplicate broadcast on ipc?)

To reproduce, just change the address in wuserver from "tcp://*:5556" to
"epgm://<server IP address>;" and in wuclient change
"tcp://localhost" to "epgm://<client IP address>;"


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130919/acce67dd/attachment.htm>

More information about the zeromq-dev mailing list