[zeromq-dev] Compile statically libzmq and czmq

Kerrigan29a kerrigan29a at hotmail.com
Wed Oct 16 01:19:27 CEST 2013


Yes, it was installed

/tmp/build/
├── [ 306]  include
│   ├── [ 13K]  zmq.h
│   └── [2.1K]  zmq_utils.h
├── [ 238]  lib
│   ├── [6.6M]  libzmq.a
│   ├── [ 921]  libzmq.la
│   └── [ 102]  pkgconfig
│       └── [ 240]  libzmq.pc
└── [ 136]  share
    └── [ 136]  man
        ├── [1.3K]  man3
        │   ├── [5.2K]  zmq_bind.3
        │   ├── [2.8K]  zmq_close.3
        │   ├── [5.2K]  zmq_connect.3
        │   ├── [3.3K]  zmq_ctx_destroy.3
        │   ├── [2.6K]  zmq_ctx_get.3
        │   ├── [2.2K]  zmq_ctx_new.3
        │   ├── [3.0K]  zmq_ctx_set.3
        │   ├── [3.1K]  zmq_disconnect.3
        │   ├── [2.6K]  zmq_errno.3
        │   ├── [ 23K]  zmq_getsockopt.3
        │   ├── [2.6K]  zmq_init.3
        │   ├── [2.8K]  zmq_msg_close.3
        │   ├── [3.1K]  zmq_msg_copy.3
        │   ├── [2.4K]  zmq_msg_data.3
        │   ├── [3.0K]  zmq_msg_get.3
        │   ├── [3.0K]  zmq_msg_init.3
        │   ├── [4.0K]  zmq_msg_init_data.3
        │   ├── [3.1K]  zmq_msg_init_size.3
        │   ├── [2.7K]  zmq_msg_more.3
        │   ├── [2.7K]  zmq_msg_move.3
        │   ├── [5.6K]  zmq_msg_recv.3
        │   ├── [5.8K]  zmq_msg_send.3
        │   ├── [2.2K]  zmq_msg_set.3
        │   ├── [2.5K]  zmq_msg_size.3
        │   ├── [6.6K]  zmq_poll.3
        │   ├── [4.4K]  zmq_proxy.3
        │   ├── [4.5K]  zmq_recv.3
        │   ├── [5.5K]  zmq_recvmsg.3
        │   ├── [4.8K]  zmq_send.3
        │   ├── [5.7K]  zmq_sendmsg.3
        │   ├── [ 23K]  zmq_setsockopt.3
        │   ├── [ 19K]  zmq_socket.3
        │   ├── [9.8K]  zmq_socket_monitor.3
        │   ├── [2.5K]  zmq_strerror.3
        │   ├── [3.4K]  zmq_term.3
        │   ├── [3.0K]  zmq_unbind.3
        │   └── [2.5K]  zmq_version.3
        └── [ 272]  man7
            ├── [8.7K]  zmq.7
            ├── [7.9K]  zmq_epgm.7
            ├── [4.2K]  zmq_inproc.7
            ├── [4.3K]  zmq_ipc.7
            ├── [7.9K]  zmq_pgm.7
            └── [4.9K]  zmq_tcp.7

El 16/10/2013, a las 00:55, Shane Hubred <shane at hubred.us> escribió:

> Hmm, verify that the zmq was installed where you think it was. I originally followed the czmq install page example:
> export CFLAGS=-I$HOME/local/include 
> export LDFLAGS=-L$HOME/local/lib64 
> ./configure
> 
> but the library was actually installed in /lib (not /lib64).
> 
> 
> On Tue, Oct 15, 2013 at 5:23 PM, Kerrigan29a <kerrigan29a at hotmail.com> wrote:
> 
> El 16/10/2013, a las 00:03, Shane Hubred <shane at hubred.us> escribió:
> 
>> I didn't use the --with-libzmq flag when I built czmq. Instead I did the following. Hope it helps.
>> export CFLAGS=-I/tmp/build 
>> export LDFLAGS=-L/tmp/build 
>> ./configure --enable-static --disable-shared --prefix=/tmp/build && make && make instal
>> Using the --with-libzmq flag should set up flags like so (from configure.ac):
>> 
>>         CFLAGS="-I${with_libzmq}/include ${CFLAGS}"
>>         LDFLAGS="-L${with_libzmq}/lib ${LDFLAGS}"
>> 
>> I thought they should, but should the “include” and “lib” parts be there? 
>> 
>> -Matt
> 
> Yes, is the same. So, as expected, I received the same error.
> 
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> 
> 
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20131016/ba7ba0e0/attachment.htm>


More information about the zeromq-dev mailing list