[zeromq-dev] CZMQ Windows: ZBeacon Self-test

HG Choi c.hogyun at gmail.com
Wed Nov 20 13:08:52 CET 2013


Hello Developers,

I have currently built the latest CZMQ library using MSVC2010 on a Windows
7 32bit machine. After building the czmq_selftest.exe, all the tests pass
except for the zbeacon test.

The czmq_selftest exe aborts with:
E: (UDP) error 'Unknown error' on bind
Assertion failed: false, file ..\..\src\zbeacon.c , line 520

The portion in code that it is failing seems to be the bind().

zbeacon.c Line 465
//  Bind to the port on all interfaces
    inaddr_t sockaddr = self->broadcast;
    if (bind (self->udpsock, (struct sockaddr *) &sockaddr, sizeof
(sockaddr)) == SOCKET_ERROR)
        s_handle_io_error ("bind");

I have tried this on more than one Windows 7 32Bit machine and it seems to
be a common problem. Maybe it is a problem in my local network? Has anyone
else experienced this or have successfully passed the self test on the same
environment? If experienced the same error, how was this resolved?

Guidance would be appreciated.

Thank you,
Ho-Gyun Choi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20131120/50ad0d96/attachment.html>


More information about the zeromq-dev mailing list