[zeromq-dev] noob help - permission issue???

Luke Gracie LG at srllc.com
Mon Nov 18 18:21:46 CET 2013


If I run the code as root - no issue, but if I run the following code as a user; I the following error:
./zeromq.test.pl
Can't locate loadable object for module ZMQ::LibZMQ3 in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/lib64/perl5/DynaLoader.pm line 11
BEGIN failed--compilation aborted at /usr/local/lib64/perl5/ZMQ/LibZMQ3.pm line 11.
Compilation failed in require at ./zeromq.test.pl line 7.
BEGIN failed--compilation aborted at ./zeromq.test.pl line 7.

### CODE for zeromq.test.pl ###
#!/usr/bin/perl

use strict;
use warnings;
use 5.10.0;

use ZMQ::LibZMQ3;
use ZMQ::Constants qw(ZMQ_SUB ZMQ_SUBSCRIBE);

my $context = zmq_init();
### CODE END ###

I'm sure I'm missing something as this (linux and 0MQ) is very new to me. I'm running on Red Hat 6. Any help for getting this working, would be greatly appreciated.

TIA

Luke






More information about the zeromq-dev mailing list