[zeromq-dev] pub-sub losing messages

Michael Keselman michael.keselman at gmail.com
Wed May 22 19:46:07 CEST 2013


Pieter,

I tried setting SNDHWM to 0, but the effect is still the same - out of
100,000 messages the subscribers get 40,000-60,000 messages. I also to make
sure that messages are not lost when the publisher exits - tried to set
linger to a large number and also delayed the publisher exit, but the
result is similar. I tried pyzmq with the similar results. I noticed that
when the subscriber's delay removed, the subscribers work fine. Feels like
something is missing


On Tue, May 21, 2013 at 3:30 PM, Pieter Hintjens <ph at imatix.com> wrote:

> On Wed, May 22, 2013 at 12:12 AM, Michael Keselman <
> michael.keselman at gmail.com> wrote:
>
>> I tries to increase HWM and also removed it altogether. It is still
>> missing messages and results are really inconstant. There is one subscriber
>> sending 100,000 messages. With one subscriber, in 3 separate runs
>> the subscriber received respectively 76005, 37488, 82121 messages  For 3
>> subscribers, the numbers were  34778/34793/35535, 42152/42549/58702,
>> 34375/38905/37519 per subscriber per run.
>>
>
> Removing HWM means you use a default of 1,000.
>
> The number of messages you get will depend on how much CPU the subscriber
> can suck to fetch its messages,
>
> Set the SNDHWM to 0, for example, this means "no limit".
>
> -Pieter
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>


-- 
-Michael Keselman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130522/bc464437/attachment.htm>


More information about the zeromq-dev mailing list