[zeromq-dev] Packet size based latency

voochuk voochuk voochuk at yahoo.com
Sun Mar 24 04:39:07 CET 2013

My company is in the process of upgrading to windows 7 and as part of this process I ran zmq 2.2 remote_lat/local_lat to test for any issues. When I run the test between one of our 3 datacenters running win 2008 r2 and windows 7 clients the latency detected by the tool is 10 times that of the others and this seems to happen only when the packet size reaches 8181 bytes ! So specifically

Host1: Win 2008 R2 zmq 2.2 
Client1: Win 7 zmq 2.2

local_lat tcp://*:5555 8180 10000 <-> remote_lat tcp://host1:5555 8180 10000
roundtrip time: x

local_lat tcp://*:5555 8181 10000 <-> remote_lat tcp://host1:5555 8181 10000
roundtrip time: 10x

The remote_thr / local_thr tests do not show any difference

I reported this to our network team who suggested the application is just written poorly and in their tests file copy works without latency (!!) so I have to remedy the application.  I am pretty confident that its not an issue with zmq per se becuase I do not have this problem from the Win7 client to our other 2 datacenters or from win xp to the datacenter in question. 

The problem is I have the burden of proving that and am not familiar with the intricacies of using standard tcp tools or wireshark to debug this issue across the multiple routers / switches involved and am hoping someone here can give me some pointers/checklist to identify the source of the problem.


More information about the zeromq-dev mailing list