[zeromq-dev] Using ZeroMQ in VS2012 C++

Nishant Mittal nmittal at rblt.com
Thu Jul 11 21:45:38 CEST 2013

I had no luck with ZeroMQ and Windows either, then someone on this list
advised to use JeroMQ and NetMQ. these are native implmentations for JAVA
and .NET. Good luck

On Wed, Jul 10, 2013 at 10:50 PM, João Malés <jpmp9 at hotmail.com> wrote:

> Hello
> Someone advised me to join this mailing list to solve my problem. I
> already tried the ZeroMq Dashboard, the StackoverFlow, MSDN and other sites
> with no luck.
> So this is it:
> i installed the ZeroMQ in python(and it's working) but i can't do it in
> Visual studio 2012 C++. I downloaded the windows installer, installed it
> and searched in the installation folder which is:
> -an "include" folder with 2 header files which i copied into my VS include
> -a "lib" folder with 3 lib files and 3 pdb files which i copied into my VS
> lib
> -a "bin" folder which i copied into my VS bin
> After this, i tried to use zmq::context_t... and zmq::socket_t... but i
> couldn't do it, it said that zmq had to be a class in order for me to use
> as a namespace. I tried to add all the libraries to the dependencies and
> still couldn't do it.
> So, after, i copied this(
> https://github.com/zeromq/cppzmq/blob/master/zmq.hpp) to a zmqhpp.h file
> which i imported to my other header file where i want to create the socket.
> Now it says:
> "1>PythonPlugIn2.obj : error LNK2019: unresolved external symbol
> __imp__zmq_close referenced in function "public: void __thiscall
> zmq::socket_t::close(void)" (?close at socket_t@zmq@@QAEXXZ)" and a bunch of
> other "unresolved" problems(12 more to be exact)
> Meanwhile i tried another thing. Instead of the windows installer i
> downloaded the .zip. I followed every step(i had to build the msvc10
> because the msvc wouldn't build) and then i added the library libzmq_d.lib
> to my dependencies. I still get the error "zmq is not a class or namespace
> name"
> Edit:Tried this(
> http://stackoverflow.com/questions/10367678/linking-to-a-static-0mq-library-in-vs?lq=1)
> also. Nothing...
> What's happening guys?
> I'm on windows 7 x-64 and on Visual Studio 2012 c++
> Thank you for the help
> João Pereira
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev



*The information contained in this communication is not intended as an 
offer or solicitation for the purchase or sale of any securities, futures, 
options, or any other investment product. This communication is not 
research, and does not contain enough information on which to make an 
investment decision. The information herein has been obtained from various 
sources. We do not guarantee its accuracy. Any opinion offered herein 
reflects Rosenblatt Securities Inc. current judgment and may change without 
notice.          Member: NYSE, SIPC, FINRA*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130711/d0205592/attachment.htm>

More information about the zeromq-dev mailing list