[zeromq-dev] MSVC2013 builds now bundled in Windows packages

Steven McCoy steven.mccoy at miru.hk
Sat Jul 6 17:55:03 CEST 2013


On 6 July 2013 02:01, Marten Feldtmann <itlists at schrievkrom.de> wrote:

> (1) libzmq-v110_xp-mt* is the library to use under XP ? (only ?)
>

The following will work under XP SP3:

   - libzmq-v90-mt-3_2_3 (x86)
   - libzmq-v100-mt-3_2_3 (x86)
   - libzmq-v110_xp-mt-3_2_3 (x86)

There are supposed to be debug libraries too (mt-gd), I'll have to find out
why they disappeared later.  *CPack *and *CMake *always change things, I
can see the libraries in the build they just didn't reach the installer.


(2) And all other libraries are working only under Vista (and newer) OS
>

Vista+

   - libzmq-v90-mt-3_2_3 (x64)
   - libzmq-v100-mt-3_2_3 (x64)

7 SP1+

   - libzmq-v110-mt-3_2_3 (x86)
   - libzmq-v110-mt-3_2_3 (x64)
   - libzmq-v120-mt-3_2_3 (x86)
   - libzmq-v120-mt-3_2_3 (x64)



> Or to be more specific: If I want to build an application running under
> XP, Vista, 7, 8 I have to work with "libzmq-v110_xp-mt*" - without
> support for XP I may choose one of all other libraries ?
>

That would be the most compatible with MSVC2012 as the compiler.

-- 
Steve-o
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130706/2af5a57d/attachment.htm>


More information about the zeromq-dev mailing list