[zeromq-dev] Using the full bandwidth of a 10 GBps link on Windows 7

Edwin van den Oetelaar edwin at oetelaar.com
Wed Jul 3 09:42:05 CEST 2013

Hello Andy,
My guess is that your performance is limited by latency, not raw bandwidth.
To saturate a 10GBps link you need to work hard.
You might need to increase the MTU (jumbo frames), tweak RX/TX buffer size
of the network stack.
You want to decrease the number of interrupts the card generates (by
streaming big chunks over the network).

Before you tried this with ZMQ have you tried simple file copy between
machines or running a tool like netperf (I know this is Linux).
Maybe ZMQ is not your problem yet, there could be many other reasons why
your performance is below expectations.

Edwin van den Oetelaar

On Wed, Jul 3, 2013 at 8:24 AM, Andy Gotz <andy.gotz at esrf.fr> wrote:

> Dear all,
> I am trying to use the full bandwidth of a 10 GBps link under Windows 7
> (32 bits) with zeromq. I do not seem to get above 1.5 GBps on average. I
> am using the remote_thr program provided as part of the zeromq
> distribution which is using push-pull. The same zeromq program uses the
> full bandwidth under Linux.
> Has anyone managed this under Windows 7? How did you do this? I have
> read about various tweaks to be applied under Windows but none of them
> helped so far. I would be interested in any/all tricks you applied.
> Thanks in advance
> Andy
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130703/f8154de4/attachment.htm>

More information about the zeromq-dev mailing list