[zeromq-dev] zmq_send and zmq_rcv fail with unknown error

Simone xbirkettx at gmail.com
Thu Jan 10 11:18:41 CET 2013

Hi Everyone

I am using logstash to receive logs from my application. The communication is 
done using ZeroMQ. The application sends to the logstash server using ZMQ_PAIR.

The connection and context creation on the application side return no error, 
however by invoking either zmq_send or zmq_recv I get -1 and errno set to 0 and 
zmq_errno() set to 128.

Unknown errors.....

Moreover, I tried changing the zmq_connect to connect to a random IP address 
does not exist and I still get a successfull connection but obviously nothing 

I am working on Windows x64 using ZeroMQ 2.2 on the client side (since this is 
the version supported by Logstash). Logstash does not seem to be the problem 
since I am quite sure the connection is not even established.

I installed ZeroMQ from http://www.zeromq.org/distro:microsoft-windows using 2.2 
for Windows 7 and using the library libzmq-v100-mt.dll for running, precompiled, 
contained in the bin directory of the installation dir.

Any idea?

thanks a lot

Simone Zandara
Network Pogrammer - Massive Ubisoft Entertainment

More information about the zeromq-dev mailing list