[zeromq-dev] ZeroMQ 3.2.2 on Linux [ My broker is not brokering ]

Alan Vogt alanovogt at gmail.com
Thu Feb 14 18:40:43 CET 2013


Hi All:

I'm trying to find a load balancing router, whether done in C or C++.

I've compiled and linked (and launched) several of the sample applications
including:
> lbbroker
> lbbroker2
> lbbroker3
> lruqueue3

Doing this with
* Ubuntu 12.10 (GNU/Linux 3.5.0-22-generic i686) 32 bit
* ZMQ 3.2.2
* Some of these samples are based on CZMQ
       which I built fresh just the other day.

My problem is that the broker never seems to broker anything.
Take lruqueue3 for instance: It compiles and links (and launches)
successfully.
But then it sits there apparently stalled, when I know that workers and
clients have been actively generating messages.

I added in some printf() statements and a request for VERBOSE, which gets
me this far:

MAIN-Checkpoint 01: Startup: Memory has been allocated.
MAIN-Checkpoint 02: Startup: ROUTER sockets have been created.
MAIN-Checkpoint 03: Startup: Endpoints have been bound.
MAIN-Checkpoint 04: Client threads have been spawned.
MAIN-Checkpoint 05: Worker threads have been spawned.
13-02-12 15:26:55 I: zloop: register ROUTER poller (0x95edbf0, 0)
MAIN-Checkpoint 06: Reactor loop will be started next.
13-02-12 15:26:55 I: zloop: polling for 3600000 msec
« NOW AN ENDLESS STALL with nothing from the »
« front end or the back end. »


Is it obvious to anyone why the broker is not recognizing anything from the
client threads or the worker threads?

Like I said, I have tried several of these examples. They all end up
unresponsive though not crashed.
In most cases I am building the samples without ANY modification at all.
I've tried with IPC and with TCP.

Thanks for any insights,

Alan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20130214/2bfc01a8/attachment.html>


More information about the zeromq-dev mailing list