[zeromq-dev] czmq runtime version detection

Chris Laws clawsicus at gmail.com
Tue Dec 17 05:21:51 CET 2013


Pyczmq may only be usable with recent versions of libzmq and czmq. Further
investigation is necessary to confirm this but a version check at install
time would be useful.

If I am using Python and the FFI module I can obtain the zmq version,
within the setup.py installer by calling the zmq_version function. Is there
any way to obtain the equivalent CZMQ version at runtime? I understand that
there are compile time #defines but I am after runtime version detection.

If there is not a method to achieve this I guess I'll submit a pull request
to add a czmq_version function somewhere. Any suggestions for which C file
would this should go in? There does not seem to be a catch-all module,
everything has its place.

Regards,
Chris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20131217/d308c1d3/attachment.htm>


More information about the zeromq-dev mailing list