[zeromq-dev] Compatibility between 2.0.10 and 2.2.0 and 3.2

Chuck Remes lists at chuckremes.com
Tue Sep 25 05:06:33 CEST 2012


On Sep 24, 2012, at 3:34 PM, Tom Wilberding wrote:

> Hi There,
> 
> We have been on 2.0.10 for the past year and a half and are planning to
> upgrade to 2.2.0 first and then move to 3.2 shortly after that.
> 
>> From a wireformat perspective, are 2.0.10 and 2.2.0 compatible? My
> understanding is that, yes, they both use the same ZMTP/1.0. And that
> 3.2 will use an improved ZMTP/2.0 protocol.
> 
> Is my understanding correct? Any additional tips or suggestions on
> running 2.0.10 and 2.2.0 on the same network?

If you are expending effort to upgrade from 2.0.10, then please go to 3.2. There is no advantage in doing an interim upgrade to 2.2.0 and then moving to 3.2. The primary effort is in testing; do it on 3.2.

cr




More information about the zeromq-dev mailing list