[zeromq-dev] Multicast and wlan0

Cem Karan cfkaran2 at gmail.com
Fri Sep 7 12:48:15 CEST 2012

IIRC, you used the address "tcp://..."  What is the EXACT URI you're using?  If you're in user-space only, it should be epgm://

Cem Karan

On Sep 6, 2012, at 6:39 PM, Will Heger wrote:

>> Try "wlan0;", i.e. prefix the adapter first.
>> The biggest issue is that you are probably only testing on one host; try
>> sending and receiving between two different hosts on the network.
> So no success on either suggestion.  I installed 2.2 with-pgm on a
> wired box and ran my producer.
> 1. I got no response from the consumer side and the consumer side
> still won't let me prefix the address with the network adapter: wlan0
> (although it lets me run without an interface).   I always get:
> Assertion failed: rc == 0 (connect_session.cpp:96)
> Aborted
> 2. Same on the producing side.  And I tried using the wired interface
> "eth0;" and again it doesn't complain when I skip the interface, but
> produces this when I add it:
> Assertion failed: rc == 0 (connect_session.cpp:84)
> Aborted
> 3. I sanity checked request/reply across the two machines and that
> worked fine, but it still wouldn't let me prefix the interface.
> Throwing:
> zmq.core.error.ZMQError: Invalid argument
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1581 bytes
Desc: not available
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20120907/d46f3d91/attachment.bin>

More information about the zeromq-dev mailing list