[zeromq-dev] Multicast and wlan0

Will Heger will.heger at gmail.com
Fri Sep 7 00:39:36 CEST 2012

> Try "wlan0;", i.e. prefix the adapter first.
> The biggest issue is that you are probably only testing on one host; try
> sending and receiving between two different hosts on the network.

So no success on either suggestion.  I installed 2.2 with-pgm on a
wired box and ran my producer.

1. I got no response from the consumer side and the consumer side
still won't let me prefix the address with the network adapter: wlan0
(although it lets me run without an interface).   I always get:

Assertion failed: rc == 0 (connect_session.cpp:96)

2. Same on the producing side.  And I tried using the wired interface
"eth0;" and again it doesn't complain when I skip the interface, but
produces this when I add it:

Assertion failed: rc == 0 (connect_session.cpp:84)

3. I sanity checked request/reply across the two machines and that
worked fine, but it still wouldn't let me prefix the interface.

zmq.core.error.ZMQError: Invalid argument

More information about the zeromq-dev mailing list