[zeromq-dev] epgm performance numbers

Rohan Bedarkar r_bedarkar at yahoo.com
Tue Oct 30 04:10:49 CET 2012


Happens only for epgm and not for TCP. Why would that be?

Sent from my iPhone

On Oct 29, 2012, at 9:14 PM, Bennie Kloosteman <bklooste at gmail.com> wrote:

> Ethernet contention ?  It is broadcasting 
> 
> On Tue, Oct 30, 2012 at 3:19 AM, Rohan Bedarkar <r_bedarkar at yahoo.com> wrote:
>> Steve,
>> 
>> I found something interesting. ZMQ roundtrip over epgm drops suddenly at one point.. Thoughts?
>> ........
>> ......
>> ...
>> 88: 143us
>> 89: 144us
>> 90: 145us
>> 91: 146us
>> 92: 147us
>> 93: 141us
>> 94: 158us
>> 95: 879us <---------------
>> 96: 4972us
>> 97: 4966us
>> 98: 4969us
>> 99: 4969us
>> 100: 5049us
>> 101: 5049us
>> 102: 5048us
>> 103: 5048us
>> 104: 5051us
>> 105: 5048us
>> 106: 5048us
>> 107: 5048us
>> 108: 5050us
>> 
>> --
>> 
>> Rohan Bedarkar
>> MS, Computer Science 
>> University of Chicago
>> rohanb at cs.uchicago.edu
>> 
>> 
>>  
>> 
>> 
>> From: Rohan Bedarkar <r_bedarkar at yahoo.com>
>> To: ZeroMQ development list <zeromq-dev at lists.zeromq.org> 
>> Sent: Thursday, October 25, 2012 12:32 PM
>> 
>> Subject: Re: [zeromq-dev] epgm performance numbers
>> 
>> Ok. Let me start with iPerf.. 
>> 
>> Will update this thread with results as I think it will be really useful to others as well.
>> 
>>  
>> --
>> 
>> Rohan Bedarkar
>> MS, Computer Science 
>> University of Chicago
>> rohanb at cs.uchicago.edu
>> 
>> 
>>  
>> 
>> 
>> From: Steven McCoy <steven.mccoy at miru.hk>
>> To: Rohan Bedarkar <r_bedarkar at yahoo.com>; ZeroMQ development list <zeromq-dev at lists.zeromq.org> 
>> Sent: Thursday, October 25, 2012 12:17 PM
>> Subject: Re: [zeromq-dev] epgm performance numbers
>> 
>> On 25 October 2012 13:04, Rohan Bedarkar <r_bedarkar at yahoo.com> wrote:
>> Unfortunately no luck. Just tried varying the multicast rates on both sides anywhere between 1000 to 10000 to even 1000000 but no change. Its a little counterintuitive that lowering rates can help especially if HWM is sufficiently high. I am using 32 bit SuSe on one side and 64 bit SuSe on the other side. 
>> 
>> Are there any configs that I might have overlooked? 
>> 
>> Both my repeater application and originating application are very light so I doubt these latencies are anywhere in there. If I simply switch to TCP the performance is really good.
>> 
>> 
>> First set a baseline with iperf.
>> 
>> Second try the performance tools in ZeroMQ.
>> 
>> Third try the performance tools in OpenPGM.
>> 
>> Due to the high watermark you have set in ZeroMQ it might be an issue previously raised:  application level throttling is required, although it need only be coarse grained.  The problem with high speed pushing into ZeroMQ means you saturate the memory bus queuing up everything and slow the entire system down causing performance to be significantly worse.
>> 
>> Reliable multicast is not easy™
>> 
>> -- 
>> Steve-o
>> 
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>> 
>> 
>> 
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>> 
>> 
>> 
>> _______________________________________________
>> zeromq-dev mailing list
>> zeromq-dev at lists.zeromq.org
>> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
> 
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121029/13ef6426/attachment.htm>


More information about the zeromq-dev mailing list