[zeromq-dev] Is czmq 1.2.0 compatible with zmq 3.2.1-rc2?

Pieter Hintjens ph at imatix.com
Fri Oct 26 02:57:02 CEST 2012


On Fri, Oct 26, 2012 at 6:08 AM, AJ Lewis <aj.lewis at quantum.com> wrote:

> I'm not seeing a FAQ for czmq - is there anywhere that lists which
> versions are compatible with which versions of zeromq?  The
> documentation on the czmq site is for v1.3.1, which hasn't been
> released yet as far as I can tell - the latest released version
> appears to be 1.2.0.  Is 1.2.0 compatible with zeromq 3.2.1-rc2?

CZMQ aims to be compatible with all versions of libzmq back to 2.1,
including the latest RC2.

It says so on the CZMQ homepage: "Supports libzmq/2.x and libzmq/3.x." :-)

You do need to configure and build CZMQ after installing libzmq. That
is, one build of CZMQ cannot work with different libzmq versions.

-Pieter



More information about the zeromq-dev mailing list