[zeromq-dev] lazy connect with zmq_connect

Rohan Bedarkar r_bedarkar at yahoo.com
Fri Oct 19 17:34:21 CEST 2012


ahhh... That explains it. 

-1 to me for not doing my homework right! :(
 
--

Rohan Bedarkar
MS, Computer Science 

University of Chicago
rohanb at cs.uchicago.edu


 




________________________________
 From: Chuck Remes <lists at chuckremes.com>
To: ZeroMQ development list <zeromq-dev at lists.zeromq.org> 
Sent: Friday, October 19, 2012 10:23 AM
Subject: Re: [zeromq-dev] lazy connect with zmq_connect
 

Click on this link:  http://zguide2.zeromq.org/page:all

Search for "slow joiner" and read the resulting text.

cr


On Oct 19, 2012, at 10:15 AM, Rohan Bedarkar wrote:

Maybe there is already a thread on this topic but couldn't find one.....
>
>
>As per the docs for zmq_connect,"The connection will not be performed immediately but as needed by ØMQ. Thus a successful invocation of zmq_connect() does not indicate that a physical connection was or can actually be established"
>
>
>
>How then do we test for a successful connection before sending the messages? It seems all my messages are getting dropped (TCP) if I send without a one microsecond sleep between connecting and sending a bunch of messages.

_______________________________________________
zeromq-dev mailing list
zeromq-dev at lists.zeromq.org
http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121019/55f3df17/attachment.htm>


More information about the zeromq-dev mailing list