[zeromq-dev] 0MQ for C#

Marten Feldtmann itlists at schrievkrom.de
Fri Nov 30 09:53:01 CET 2012


Yes, this is a strange situation under C#.

The authors of 0MQ suggest to use only the 3.2 version and then you get 
a new wrapper - suitable for .NET 4.0 (or Mono 2.8 and up).

If you have to use .NET 3.5 (or Mono 2.6), then you must use the 
different wrapper for 0MQ 2.2 (which results in a different source code 
for your application).

One case of using this older wrapper is when one is using Unity3D 
together with 0MQ - Unity3D (3.x or 4.x) only supports Mono 2.6.

In our case we now have to write two different wrappers around the basic 
wrapper to have the same API to our applications.

By the way: what I found pretty difficult when coming from the C API 
level: The handling of exception in the .NET wrapper.



Marten



More information about the zeromq-dev mailing list